[project @ 2004-12-04 14:07:25 by panne]
[ghc-hetmet.git] / ghc / configure.ac
index cc5eaa1..0099027 100644 (file)
@@ -23,6 +23,17 @@ FP_GCC_NEEDS_NO_OMIT_LFPTR
 # Check whether this GHC has readline installed
 FP_GHC_HAS_READLINE
 
+# test for GTK+
+AC_PATH_PROGS([GTK_CONFIG], [gtk-config gtk12-config])
+if test -n "$GTK_CONFIG"; then
+  AC_CACHE_CHECK([for version of GTK+], [fp_cv_gtk_version],
+    [fp_cv_gtk_version=`$GTK_CONFIG --version`])
+  FP_COMPARE_VERSIONS([$fp_cv_gtk_version], [-lt], [1.2],
+    [AC_MSG_WARN([GTK+ not usable, need at least version 1.2])
+     GTK_CONFIG=])
+fi
+AC_SUBST([GTK_CONFIG])
+
 # Write the results...
 AC_CONFIG_FILES([ghc.spec VERSION docs/users_guide/ug-book.xml mk/config.mk mk/version.mk])
 AC_OUTPUT