[project @ 2004-09-18 12:49:55 by panne]
[ghc-hetmet.git] / ghc / configure.ac
index 2d9e602..040041d 100644 (file)
@@ -1,15 +1,11 @@
 # Initialise and check sanity.
-AC_INIT([ghc.spec.in])
+AC_INIT([Glasgow Haskell Compiler], [6.3], [glasgow-haskell-bugs@haskell.org], [ghc])
+AC_CONFIG_SRCDIR([ghc.spec.in])
 
-# Compute the version number.
-version=`sed -e 's/.*\([[0-9]]\)\.\([[0-9]]*\).*/\1.\2/' VERSION`
-
-# ToDo: CVS snapshots should probably use the date here
-release=1
-
-# These are needed by the .spec file.
-AC_SUBST([version])
-AC_SUBST([release])
+# Compute the version number and the release, they are needed by the .spec file.
+AC_SUBST([version], [[`sed 's/.* version \([0-9][0-9.]*\).*/\1/' VERSION`]])
+AC_SUBST([release], [1])
 
 # Write the results...
-AC_OUTPUT([ghc.spec])
+AC_CONFIG_FILES([ghc.spec])
+AC_OUTPUT