[project @ 2004-11-09 10:42:47 by simonmar]
[ghc-hetmet.git] / ghc / configure.ac
index 2075912..9e4d6cd 100644 (file)
@@ -1,16 +1,8 @@
 # Initialise and check sanity.
-AC_INIT([Glasgow Haskell Compiler], [6.3.20040927], [glasgow-haskell-bugs@haskell.org], [ghc])
+AC_INIT([The Glorious Glasgow Haskell Compilation System], [6.3], [glasgow-haskell-bugs@haskell.org], [ghc])
 AC_CONFIG_SRCDIR([ghc.spec.in])
 
-# Calculate project version as an integer, using 2 digits for minor version
-case $PACKAGE_VERSION in
-  *.?)  ProjectVersionInt=`echo "$PACKAGE_VERSION" | sed 's,^\(.*\)\.\(.\)$,\10\2,'` ;;
-  *.??) ProjectVersionInt=`echo "$PACKAGE_VERSION" | sed 's,^\(.*\)\.\(..\)$,\1\2,'` ;;
-  *.?.*)  ProjectVersionInt=`echo "$PACKAGE_VERSION" | sed 's,^\(.*\)\.\(.\)\.\(.*\)$,\10\2,'` ;;
-  *.??.*) ProjectVersionInt=`echo "$PACKAGE_VERSION" | sed 's,^\(.*\)\.\(..\)\.\(.*\)$,\1\2,'` ;;
-  *) AC_MSG_ERROR([bad package version $PACKAGE_VERSION]) ;;
-esac
-AC_SUBST([ProjectVersionInt])
+FP_SETUP_PROJECT_INFO
 
 # Hmmm, we fix the RPM release number to 1 here... Is this convenient?
 AC_SUBST([release], [1])