Fix a bug related to threads blocked on blackholes
[ghc-hetmet.git] / ghc / configure.ac
index 0099027..b6d9a4c 100644 (file)
@@ -1,5 +1,5 @@
 # Initialise and check sanity.
-AC_INIT([The Glorious Glasgow Haskell Compilation System], [6.3], [glasgow-haskell-bugs@haskell.org], [ghc])
+AC_INIT([The Glorious Glasgow Haskell Compilation System], [6.5], [glasgow-haskell-bugs@haskell.org], [ghc])
 AC_CONFIG_SRCDIR([ghc.spec.in])
 
 # duplicate from ../configure.ac
@@ -24,13 +24,14 @@ FP_GCC_NEEDS_NO_OMIT_LFPTR
 FP_GHC_HAS_READLINE
 
 # test for GTK+
-AC_PATH_PROGS([GTK_CONFIG], [gtk-config gtk12-config])
+AC_PATH_PROGS([GTK_CONFIG], [pkg-config])
 if test -n "$GTK_CONFIG"; then
-  AC_CACHE_CHECK([for version of GTK+], [fp_cv_gtk_version],
-    [fp_cv_gtk_version=`$GTK_CONFIG --version`])
-  FP_COMPARE_VERSIONS([$fp_cv_gtk_version], [-lt], [1.2],
-    [AC_MSG_WARN([GTK+ not usable, need at least version 1.2])
-     GTK_CONFIG=])
+  if $GTK_CONFIG gtk+-2.0 --atleast-version=2.0; then
+    GTK_CONFIG="$GTK_CONFIG gtk+-2.0"
+  else
+    AC_MSG_WARN([GTK+ not usable, need at least version 2.0])
+    GTK_CONFIG=
+  fi
 fi
 AC_SUBST([GTK_CONFIG])