Fix a bug related to threads blocked on blackholes
[ghc-hetmet.git] / ghc / configure.ac
index 338678c..b6d9a4c 100644 (file)
@@ -1,37 +1,40 @@
 # Initialise and check sanity.
-AC_INIT(ghc.spec.in)
+AC_INIT([The Glorious Glasgow Haskell Compilation System], [6.5], [glasgow-haskell-bugs@haskell.org], [ghc])
+AC_CONFIG_SRCDIR([ghc.spec.in])
 
-# Compute the version number.
-version=`sed -e 's/.*\([[0-9]]\)\.\([[0-9]]*\).*/\1.\2/' VERSION`
-patchlevel=1
+# duplicate from ../configure.ac
+AC_ARG_WITH([ghc],
+[AC_HELP_STRING([--with-ghc=ARG],
+  [Use ARG as the path to GHC  [default=autodetect]])],
+  [WithGhc="$withval"],
+  [if test "$GHC" = ""; then
+    AC_PATH_PROG([GHC], [ghc])
+  fi
+  WithGhc="$GHC"])
+AC_SUBST([WithGhc])
 
-# These are needed by the .spec file.
-AC_SUBST(version)
-AC_SUBST(patchlevel)
+FP_SETUP_PROJECT_INFO
 
-# Uncomment links to unix docs if necessary.
-# NOTE: This is a slight hack: It needs to be synchronized with
-# fptools/configure.ac and fptools/libraries/Makefile and should probably use
-# target features instead of host.
-AC_CANONICAL_HOST
+# Hmmm, we fix the RPM release number to 1 here... Is this convenient?
+AC_SUBST([release], [1])
 
-case $host in
-i[[3456]]86-*-mingw32*) fp_supports_unix=no  ;;
-*)                      fp_supports_unix=yes ;;
-esac
-FP_HTML_COMMENT([test x"$fp_supports_unix" = xyes], [unix])
+FP_GCC_NEEDS_NO_OMIT_LFPTR
 
-# Uncomment links to ObjectIO docs if necessary.
-AC_ARG_ENABLE([objectio],
-  AC_HELP_STRING([--enable-objectio],
-                 [Build ObjectIO, a portable GUI library for Haskell.]))
-FP_HTML_COMMENT([test x"$enable_objectio" = xyes], [ObjectIO])
+# Check whether this GHC has readline installed
+FP_GHC_HAS_READLINE
 
-# Uncomment links to HOpenGL docs if necessary
-AC_ARG_ENABLE([hopengl],
-  AC_HELP_STRING([--enable-hopengl],
-                 [Build HOpenGL, a Haskell binding for OpenGL/GLUT.]))
-FP_HTML_COMMENT([{ test x"$enable_hopengl" = xyes || test x"$enable_hopengl" = xx11; }], [HOpenGL])
+# test for GTK+
+AC_PATH_PROGS([GTK_CONFIG], [pkg-config])
+if test -n "$GTK_CONFIG"; then
+  if $GTK_CONFIG gtk+-2.0 --atleast-version=2.0; then
+    GTK_CONFIG="$GTK_CONFIG gtk+-2.0"
+  else
+    AC_MSG_WARN([GTK+ not usable, need at least version 2.0])
+    GTK_CONFIG=
+  fi
+fi
+AC_SUBST([GTK_CONFIG])
 
 # Write the results...
-AC_OUTPUT(ghc.spec docs/libraries.html)
+AC_CONFIG_FILES([ghc.spec VERSION docs/users_guide/ug-book.xml mk/config.mk mk/version.mk])
+AC_OUTPUT