[project @ 2004-11-08 12:26:52 by simonmar]
[ghc-hetmet.git] / ghc / configure.ac
index 31d06a6..d29e847 100644 (file)
@@ -1,13 +1,12 @@
 # Initialise and check sanity.
-AC_INIT([ghc.spec.in])
+AC_INIT([The Glorious Glasgow Haskell Compilation System], [6.3.20041107], [glasgow-haskell-bugs@haskell.org], [ghc])
+AC_CONFIG_SRCDIR([ghc.spec.in])
 
-# Compute the version number.
-version=`sed -e 's/.*\([[0-9]]\)\.\([[0-9]]*\).*/\1.\2/' VERSION`
-patchlevel=1
+FP_SETUP_PROJECT_INFO
 
-# These are needed by the .spec file.
-AC_SUBST(version)
-AC_SUBST(patchlevel)
+# Hmmm, we fix the RPM release number to 1 here... Is this convenient?
+AC_SUBST([release], [1])
 
 # Write the results...
-AC_OUTPUT([ghc.spec])
+AC_CONFIG_FILES([ghc.spec VERSION docs/users_guide/ug-book.xml mk/version.mk])
+AC_OUTPUT