[project @ 2004-08-31 16:19:54 by panne]
[ghc-hetmet.git] / ghc / configure.ac
index 2d9e602..efbf7d0 100644 (file)
@@ -1,15 +1,9 @@
 # Initialise and check sanity.
 AC_INIT([ghc.spec.in])
 
-# Compute the version number.
-version=`sed -e 's/.*\([[0-9]]\)\.\([[0-9]]*\).*/\1.\2/' VERSION`
-
-# ToDo: CVS snapshots should probably use the date here
-release=1
-
-# These are needed by the .spec file.
-AC_SUBST([version])
-AC_SUBST([release])
+# Compute the version number and the release, they are needed by the .spec file.
+AC_SUBST([version], [[`sed 's/.* version \([0-9][0-9.]*\).*/\1/' VERSION`]])
+AC_SUBST([release], [1])
 
 # Write the results...
 AC_OUTPUT([ghc.spec])