[project @ 2003-07-24 15:12:35 by simonmar]
[ghc-hetmet.git] / ghc / configure.in
index ac52dc5..7a4f062 100644 (file)
@@ -20,5 +20,61 @@ dnl These are needed by the .spec file.
 AC_SUBST(version)
 AC_SUBST(patchlevel)
 
+dnl Uncomment links to unix docs if necessary dnl NOTE: This is a slight
+dnl hack: It needs to be synchronized with fptools/configure.in and
+dnl fptools/libraries/Makefile and should probably use target features
+dnl instead of host.
+AC_CANONICAL_HOST
+
+case $host in
+i[3456]86-*-mingw32*)
+       unixHTMLStart="<!--"
+       unixHTMLEnd="-->"
+       ;;
+*)
+       unixHTMLStart=""
+       unixHTMLEnd=""
+       ;;
+esac
+
+AC_SUBST(unixHTMLStart)
+AC_SUBST(unixHTMLEnd)
+
+dnl Uncomment links to ObjectIO docs if necessary
+AC_ARG_ENABLE(objectio,
+[  --enable-objectio
+        Build ObjectIO, a portable GUI library for Haskell.
+],
+[
+ObjectIOHTMLStart=""
+ObjectIOHTMLEnd=""
+],
+[
+ObjectIOHTMLStart="<!--"
+ObjectIOHTMLEnd="-->"
+]
+)
+
+AC_SUBST(ObjectIOHTMLStart)
+AC_SUBST(ObjectIOHTMLEnd)
+
+dnl Uncomment links to HOpenGL docs if necessary
+AC_ARG_ENABLE(hopengl,
+[  --enable-hopengl
+        Build HOpenGL, a Haskell binding for OpenGL/GLUT.
+],
+[
+HOpenGLHTMLStart=""
+HOpenGLHTMLEnd=""
+],
+[
+HOpenGLHTMLStart="<!--"
+HOpenGLHTMLEnd="-->"
+]
+)
+
+AC_SUBST(HOpenGLHTMLStart)
+AC_SUBST(HOpenGLHTMLEnd)
+
 dnl * Write the results...
-AC_OUTPUT(ghc.spec)
+AC_OUTPUT(ghc.spec docs/libraries.html)